Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Wi Spy Vista Win7

  1. #11

    Default 2.4x doesnt work on windows 7 here either

    and I have .net installed and enabled.
    it comes up and says installation of hardware failed, looking for a driver.

    i have windows 7 64bit system for that.

    on two other windows xp pro 32 bit systems, one of them it doesnt even see the device when I connect it, at all.

    the other one, it locks up the usb part way through detecting it, and I then can't plug in any more usb devices, they won't work.

    i just got this 2.4x delivered yesterday.

    my linux system seems to see it, but I havent been able to get kismet to work with it yet.

  2. #12


    I got an old Dell D610 working, winxp pro 32bit.

    so at last I can see the tools and I know my unit works.

    the 2 xp systems are Dell D630's I'll try some more tomorrow.
    win7 is also on Dell D630
    linux is an amd quad-phenom 3ghz 64bit opensuse 11.1
    kismet can't see the interface, linux never creates it tho dmesg sees it as a metageek wispy 2.4x - sorry if some of this is repeated.

  3. #13


    Well, I don't have a 2.4x, but my 2.4i and v1 both work with my Windows 7 Pro 64Bit. They also work on the 32 Bit versions of 7, XP and Vista.

    The WiSpys don't require any special driver, they show up as an HID device. (like keyboards and mice). Windows should see it and install a generic HID driver. It should just work. Hmm.

  4. #14


    Well the windows7 here definitely not working at all.
    No HID is ever setup that I can see.
    .net framework is installed.

    some better news on the winxp front though,
    the system that had the USB locking up yesterday is now working nicely.
    I plugged the wi-spy into the docking station usb rather than directly.

    2 down, 3 to go.
    I'm pretty sure I can get the other dell630 winxp working as well using the same method.

    so windows 7 is still stuck, and not sure what's up with the linux box, I'll try another port. suse 11.x has usb bugs on amd platform that they're not fixing.

  5. Default

    I talked to him in real life. It looks like he was trying to use the Wi-Spy as a network interface. Chanalyzer and Wi-Spy do work in Windows 7.

  6. #16


    I' having the same issues with my DBx. Any time frame for having it work on Windows 7? And 64-bit computers?

  7. Default

    I'm running Chanalyzer on Windows 7 64 bit right now... Which problems are you having?

    The previous customer was trying to select the Wi-Spy as a network adapter to capture SSIDs, which isn't possible.

  8. #18

    Default My DBx suddenly started acting up


    I have a Wi-Spy DBx for a year now or so. I have used it on many computers and OS-es - no problems until today. This morning I plugged in the DBx in the same USB-port I normally use on my Desktop Win7_64bit system. I used it on this computer less than a week ago - no problems.

    However, this time, Windows reports

    "USB Device Not Recognized
    One of the USB Devices attached to this computer has malfunctioned, and Windows does not recognize it. For Assistance in solving this problem, click this message."

    Her is what I have tried:

    - All other USB-ports on this computer: No luck
    - Rebooting computer (amd also shutting down and powering off): No luck
    - Uninstall/reinstall SW: no luck
    - Other computers:
    * Win7_32bit laptop: consistently works on all 4 USB ports on docking station, but not on any of the 3 ports on laptop itself (even when undocked). The 3 ports on the laptop works fine with other USB-devices I have. I know this sounds crazy, but this is how it is.

    * Vista 332bit laptop: Works

    Please, someone - any ideas?

    Kind regards

  9. Default

    Hi Dag,

    Thank you for posting. Whether Windows correctly installs the USB driver, the Wi-Spy can will usually still function with Chanalyzer. A good way to test this is to Start Chanalyzer with the Wi-Spy plugged in. While Chanalyzer is running unplug the Wi-Spy. The Density View, Waterfall and Planar View should disappear.

    If you have the Wi-Spy plugged in, and only the start up screen appears, send me a personal message or give me a call. There are a few other things we can try.


  10. #20


    Hi Trent!

    Thanks for your suggestion. I did some more research on the matter and found that the adapter only worked when using it on a docking station or with a USB HUB. It seems that it will not work on USB2.0. I sent the adapter back to the store. They confirmed my findings and sent me a replacement adapter.

    Kind regards

Page 2 of 4 FirstFirst 1234 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts