Results 1 to 4 of 4

Thread: Chanalyzer crashing on startup

  1. #1

    Default Chanalyzer crashing on startup

    Have Intel chipset and Win Zero Conf is set. (Intel native disabled)
    Chan 3.4 work fine. last v 4 worked but was very unstable. The latest won't start.


    Microsoft Windows NT 5.1.2600 Service Pack 3


    System.NullReferenceException: Objektreferensen har inte angetts till en instans av ett objekt.
    vid MetaGeek.Controller.DeviceClassification.Classifie rController.()
    vid MetaGeek.Controller.DeviceClassification.Classifie rController.()
    vid MetaGeek.Controller.DeviceClassification.Classifie rController.Initialize()
    vid MetaGeek.View.ViewCollection.ReconfigureController s()
    vid .. ()
    vid ..(Int32 )
    vid ..(Object , DeviceManagerEventArgs )
    vid System.EventHandler`1.Invoke(Object sender, TEventArgs e)
    vid MetaGeek.WiSpy.DeviceManager.InvokeDeviceInitializ edEvent(DeviceManagerEventArgs e)
    vid MetaGeek.WiSpy.DeviceManager.InitializeDevice(WiSp yDatabaseHandler dataFileHandler)
    vid MetaGeek.WiSpy.DeviceManager.HidMonitor_DeviceDisc overedEvent(Object sender, DeviceEventArgs e)
    vid MetaGeek.WiSpy.HidMonitor.InvokeDeviceDiscoveredEv ent(DeviceEventArgs e)
    vid MetaGeek.WiSpy.HidMonitor.FindCurrentlyConnectedDe vices()
    vid MetaGeek.WiSpy.HidMonitor.Start()
    vid MetaGeek.WiSpy.DeviceManager.Start()
    vid ..()
    vid ...ctor(String[] )
    vid . .(String[] )

  2. #2



    I have the same error, but now my Wi-Spy Dbx doen't work with the Chanalyzer v3.4.

  3. #3


    Same problem here on a Swedish OS.
    Tested both on Win 7 32 and 64bit.

  4. #4


    Same problem, error on chanalyser 4 and my dbx isn't recognize on chanalyser 3.4 and with spectool (linux). I think the problem is the new dbx firmware. Is it possible to come back to the old version?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts