Results 1 to 2 of 2

Thread: Getting VirtualBox to recognize and load your Wi-Spy

  1. #1

    Lightbulb Getting VirtualBox to recognize and load your Wi-Spy

    VirtualBox 4.0.8
    Host: Mac OS X
    Guest: Windows XP
    Wi-Spy model: DBx
    Chanalyzer: Pro


    Thanks to Wi-Spy user Rod for documenting his experiences and allowing us to post his notes for others. These aren't step-by-step instructions, so please read the whole post before starting.

    “I had found something similar to these about the vboxuser but that article made it sound like the account/group should already exist which of course it doesn't.

    So I tried the process on the*link you sent*and had no luck with getting the Wi-Spy to become "available" by adding a group and trying to change permissions but down in the comments of that same page is someone that had no luck either but found a solution:

    'I found by removing in the USB-filter all info except the Product Name, Vendor ID and Revision and replugging, it works!'

    So I removed the vboxusers group and created a new USB filter in vbox and filled in the 3 items mentioned above (as letting vbox auto populate them and then removing the extra data failed too) and then unplugged and plugged back in the adapter and boom...all is good.”

    “Hello again,

    I thought I had figured out the issue with the way to add the USB filter but I was mistaken. I wanted to correct my findings in case you find this useful with any other customers.

    Actually, vbox has an issue with using more than 1 cpu in a WinXP (maybe other versions too, did not test more than XP) that causes USB issues.* As soon as I went down to 1 cpu I have had USB drives and the Wi-Spy device all work after any number of reboots, shutdowns, device removals (not the case running 2 cpus in vbox).

    The only thing that happens like clockwork is this:* When I first plug in the Wi-Spy, Vbox sees it, I launch Chanalyzer, the app instantly crashes with a windows message "want to send a report...", then the USB icon starts flashing with crazy activity, then I know it is ready to launch Chanalyzer again without issue.* I have not got around the first launch-crash-re-launch combo yet, but at this point I dont care because it works in the end.* I can wait for a while and the icon never triggers activity for me until I try to launch the app to start the ball rolling.”

    “I followed this test up on another laptop with the same version of Vbox running (4.0.8), and the same XP completely updated.** This extra test was to prove/confirm that I did NOT need to create the vboxusers group, add my account to it, change permissions for the USB functionality to work with the Wi-Spy device.** Both my systems work the same, with and without the whole vboxusers group steps.

    So all-in-all I only had to make a vbox usb adapter filter, make sure I was using 1 cpu in the VM setup, and connect the device once the VM loaded.”

  2. #2

    Default

    VirtualBox 4.1.8 on Linux-Ubuntu 11.04 (Natty), with Windows XP SP2 installed on.
    Needed .Net Framework 3.5 and Windows INstaller 3.1 to install prior Chanalyzer 4 installation.

    Special settings in VirtualBox : chipset PIIX3 (and not ICH9) in system settings, I installed the guest additions, and the extension pack in order to get USB 2.0 support.

    I'm not sure if the extension pack is really needed, because I installed it before doing the last and important trick : adding your user to 'vboxusers' group on your computer (it has been created by the installer) AND log out and in for that setting to be active ! (that's what I forgot at the first time).

    I'm running a 2.4x wi spy but it should be the same for the new dbx stick.

    Michel

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •