Results 1 to 10 of 10

Thread: Other .NET framework version than 3.5 support?

  1. #1

    Default Other .NET framework version than 3.5 support?

    I need another version (updated?) of inSSIDer, which does not require .NET framework v3.5.

    I have all other ones in my system (1.1, 2.0, 3.0, 4.0), but the 3.5 .NET can not be installed, the installer always throws an error. Many people have this problem - see Google.

    The v4.0 is backward compatible, but the inSSIDer requires only the 3.5 and refuses to be installed

    If the developer reads this post: please, could you make a version which won't need the v3.5 of .NET?

  2. #2

    Default

    redfox,

    Are you saying you've tried .NET4 and it didn't work? I am running .NET4 and inSSIDer installs and runs just fine.

    http://msdn.microsoft.com/en-us/netframework/aa569263

    Stephen

  3. #3

    Default

    @Stephen:

    .NET 3.5 uses a different runtime version than .NET 4. v3.5 uses the v2.0 CLR, while .NET 4.0 uses the v4.0 CLR.
    If a program is compiled for v3.5, it requires .NET 3.5 to be installed. It will not run on .NET 4.0.

    inSSIDer is compiled for .NET 3.5, not 4.0.
    The reason inSSIDer works for you is because you have .NET 3.5 installed along with 4.0.

  4. #4

    Default

    Tyler,

    Yes, you are correct. I just misread his question. I thought he was saying that v3.5 was working and v4.0 wasn't installing. But this was not the case. Forgive me, it's dead week and next week is finals

    redfox,

    Are you downloading your 3.5 installer from http://msdn.microsoft.com/en-us/netframework/cc378097 (Scroll to the bottom where it says .NET Framework 3.5). This is the link I have used with my new laptop and on other friends' computers and it always installs fine. I'm just not sure if you are getting your download link from somewhere else other than MSDN.microsoft.com

    I've never had problems with any of my .NET frameworks installing, so my experience with troubleshooting an issue like this isn't much

    Stephen
    Last edited by Stephen; 05-01-2012 at 01:41 PM.

  5. #5

    Default

    I am having this same issue. I have an older version of inSSIDer version 2.0.6.1208, it works good, but I can't apply the updates. Because the updates want me to download .NET Framework 3.5 [NF], but every time I try to do that it won't install. The download update doesn't specify which NF 3.5 I need, so ?

    I currently have NF 4 Client installed. The above link has 4 different versions of NF 3.5, how does one decipher which one to use?

    I have run NF Set Up Verifier previously and it is rather confusing to read. But I see that it verifies I have NF 2.0 SP2, NF 3.0 SP2, NF 3.5 SP1, and NF 4 Client installed.

    The Set Up Verifier shows the following NF as not installed: NF 4.0 Full, 1.0, 1.1, 1.1 SP1, 2.0, 2.0 SP1, 3.0, 3.0 SP1, and 3.5.
    I would insert the whole report, but don't see a download link?

    I am running Vista 32 bit OS premium. So if anyone has a clue what to do, I'm all ears.

    Thanks, Bill

  6. #6

    Default

    housing,

    Here is a direct link http://www.microsoft.com/en-us/downl...ils.aspx?id=21

    If this doesn't work then you will need to stick with v2.0.6 until we release our next inSSIDer It will be out sometime soon

    Stephen

  7. #7

    Default

    Belated thanks. I tried installing Net Framework [NF] 3.5 again, but no luck. It downloads the program, gets to a certain point and shows a Setup Error pop-up. I may have to do a Windows reinstall to fix the NF installation problem or upgrade to a newer version.

    But thanks anyway.

  8. #8

    Default

    Hey, back again. I am still using the InSSIDer 2.0.6.1208 version. Works okay, keeps me informed of available connections, etc.

    But as stated above NetFramework 3.5 won't install on my machine, tried many times. I have only 2.0 NF currently working on my machine, and assume that is why the 2.0.6.1208 version works. I try to install the newer updated versions as they come, but no luck, as they also need NF 3.5 to install.

    So I guess my question is: Will any of the newer versions install with NF 2.0?

    Thanks, housing.

  9. Default

    Hi Housing,

    inSSIDer requires both .Net 3.5 and .Net 4.5 to run properly. .Net 4.5 is not backwards compatible with 3.5, they both need to be installed. If you are unable to install .Net 3.5, and you are out of options, you might have to resort to a clean installation of Windows, which I've found needs to happen from time to time. Good luck!

  10. #10

    Default

    Sounds like what I'm going to do. Clean install a new Win 7 OS. After I figure how to partition a new HDD.

    Thanks, housing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •