Results 1 to 2 of 2

Thread: Chanalyzer 4.2.1.28 won't start/open on Win7 x64

  1. #1

    Default Chanalyzer 4.2.1.28 won't start/open on Win7 x64

    ** Please provide a brief description of what was happening immediately prior to this error **

    [Description]
    Plugged in my Wi-Spy 2.4x and clicked the shortcut for Chanalyzer in the Start menu.

    This is actually a 64-bit machine/OS... apparently your debugger reports x86 because it's a 32-bit program.
    Also, when I clicked Send Report, it said I have no email client installed, but Windows Mail was running at the time that message popped up, and it does report itself as the default email and news handler.
    Click image for larger version. 

Name:	WindowsMailDefault.png 
Views:	314 
Size:	28.2 KB 
ID:	825

    I don't see anywhere in the Chanalyzer FAQ where to email crash reports manually, so I'm posting it here.


    [Message]
    The added or subtracted value results in an un-representable DateTime.
    Parameter name: t

    [Version]
    4.2.1.28

    [WinVer]
    Microsoft Windows NT 6.1.7601 Service Pack 1

    [Platform]
    x86

    [StackTrace]
    at System.DateTime.op_Subtraction(DateTime d, TimeSpan t)
    at MetaGeek.LabBasic.HorizontalPlaybackControl.Horizo ntalPlaybackController.k()
    at MetaGeek.LabBasic.HorizontalPlaybackControl.Horizo ntalPlaybackController.d()
    at MetaGeek.LabBasic.HorizontalPlaybackControl.Horizo ntalPlaybackController.f()
    at MetaGeek.LabBasic.HorizontalPlaybackControl.Horizo ntalPlaybackController.a()
    at MetaGeek.LabBasic.HorizontalPlaybackControl.Horizo ntalPlaybackController.SweepDeviceManager_SweepRea dEvent(Object sender, DataEventArgs`1 e)
    at MetaGeek.Diagnostics.Event.EventHelper.Raise[T](EventHandler`1 handler, Object sender, T eventArgs)
    at MetaGeek.Diagnostics.Event.RegisteredEventHandler` 1.Raise(Object sender, T eventArgs)
    at MetaGeek.WiSpy.SweepDeviceManager.a(Object A_0, DataEventArgs`1 A_1)
    at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
    at MetaGeek.Diagnostics.Event.EventHelper.Raise[T](EventHandler`1 handler, Object sender, T eventArgs)
    at MetaGeek.Diagnostics.Event.RegisteredEventHandler` 1.Raise(Object sender, T eventArgs)
    at MetaGeek.WiSpy.SweepDevice.InvokeSweepReadEvent(Sw eepData sweepPacket)
    at MetaGeek.WiSpy.Devices.WiSpy24X.a()
    at System.Threading.ThreadHelper.ThreadStart_Context( Object state)
    at System.Threading.ExecutionContext.Run(ExecutionCon text executionContext, ContextCallback callback, Object state)
    at System.Threading.ThreadHelper.ThreadStart()


    That's all that was in the report from the 'copy to clipboard' button on the report dialog.

    I uninstalled it and reinstalled it, but it still won't open... I see it on the Processes tab in Task Manager, using 58MB of memory, but it doesn't open. There are no log files present in C:\Program Files (x86)\MetaGeek\Chanalyzer4.

    Product: Chanalyzer 4 -- Error 1316. A network error occurred while attempting to read from the file: C:\Downloads\Installs\Metageek\Chanalyzer\Chanalyz er-4-(4)-Installer.msi
    Event ID 11316

    is the only thing I can find in Event Viewer for Chanalyzer, which happened the first time I tried to reinstall it... uninstalling the previous copy and starting the install again successfully completed.

    Thanks.

  2. #2

    Default

    Thanks for posting that up for us. It looks like an error report for this issue has been reported, so the development team is aware of the issue. What's new is that usually closing and opening Chanalyzer again solves the problem - not the case here.

    You mentioned reinstalling Chanalyzer. After reinstalling, is it working again or are you still having this problem? Let me know, thanks!
    Joel, Mobility+, ECSE, CWNE #233
    Technical Trainer
    MetaGeek

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •