Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Visual C# Command Line Compiler has stopped working

  1. #1

    Default Visual C# Command Line Compiler has stopped working

    Windows 7 64-bit, current
    inSSIDer Home version

    I'm getting this Windows error upon inSSIDer startup. inSSIDer then fails to start. I have tried removing and re-installing inSSIDer, as well as rebooting.

  2. Default

    The first thing I would try is reinstalling the .NET Framework 4.0. That generally takes care of startup issues like that.

  3. #3



    1. Reinstalled .NET Framework 4 using your link.
    2. Tried inSSIDer, same result.
    3. Rebooted.
    4. Tried inSSIDer, same result.
    5. Installed 5 new Windows updates for .NET Framework 4.
    6. Tried inSSIDer, same result.
    7. Rebooted.
    8. Tried inSSIDer, same result.

    A. Any point in installing inSSIDer for the third time?

    B. Is there a log or something that would provide more insight into the failure?

    C. Any other suggestions?

  4. #4


    Have you looked in Windows event logs?
    Old Mod by the Sea

  5. #5


    Quote Originally Posted by ua549 View Post
    Have you looked in Windows event logs?
    I see the following application error. It is followed by a second one for inSSIDer, but I will omit that one since it's presumably caused by the first.

    Faulting application name: csc.exe, version: 4.0.30319.1, time stamp: 0x4ba20a1b
    Faulting module name: csc.exe, version: 4.0.30319.1, time stamp: 0x4ba20a1b
    Exception code: 0xc0000005
    Fault offset: 0x000ac4c5
    Faulting process id: 0x1fe0
    Faulting application start time: 0x01ce743ac60d7ad1
    Faulting application path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\csc. exe
    Faulting module path: C:\Windows\Microsoft.NET\Framework\v4.0.30319\csc. exe
    Report Id: 0502c6ca-e02e-11e2-b31e-8773a871ae09

  6. #6



    I have another version of csc.exe, at C:\Windows\Microsoft.NET\Framework64\v4.0.30319\cs c.exe. Note Framework64. This version is considerably larger than the failing one.

    Given that I'm running 64-bit Windows, should I be using this version instead?


  7. #7


    I'm not a coder, sorry.
    On my Windows Ultimate (x64) I have both net versions. 32 bit and 64 bit csc.exe file sizes are 1815 KB and 2619 KB respectively.
    Both the 32 bit version 4.0.30319 and the 64 bit version 4.0.30319 have a configuration file of 
    <?xml version ="1.0"?>
        <startup useLegacyV2RuntimeActivationPolicy="true">
            <supportedRuntime version="v4.0.30319"/>
    Old Mod by the Sea

  8. #8


    I ran CHKDSK and it found no errors.

    Clearly, something in my system is corrupted, and it's something that wasn't replaced when I re-installed .NET Framework 4. I don't care to re-install Windows, thanks.

    I don't know if this is significant, but the Created, Modified, and Accessed dates for both copies of csc.exe are in 2010. If they were replaced when I re-installed .NET Framework 4, I would have expected something there to change.

    If there are no other ideas/suggestions, can someone recommend an alternative to inSSIDer (other than Smith & Wesson) that will help me avoid interference from my next door neighbor? My computer usually shows his network with a signal as strong as mine, sometimes a little stronger. Although I haven't spoken to him, it's very possible that I'm closer to his router than to mine, with only a couple of windows between us.

    Obviously I would need something that doesn't use the C# Command Line Compiler.

  9. #9


    Have you run the system file checker? Run sfc /scannow from a CMD window to find corrupt system files.
    Old Mod by the Sea

  10. #10


    C:\Windows\system32>sfc /scannow

    Beginning system scan. This process will take some time.

    Beginning verification phase of system scan.
    Verification 16% complete.
    Windows Resource Protection found corrupt files but was unable to fix some of them.
    Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log

    So I went through the thousands of messages in CBS.log. I saw a couple of dozen "Error" messages, but nothing that meant anything to me.

    I think I've found what I need in NetSurveyor. Interestingly, NetSurveyor says it requires "Microsoft .NET Framework version 3.5 (or later)" but it works anyway.

    I know you guys have better things to do than help me correct a system corruption that has nothing to do with inSSIDer. Provided it doesn't impact me more severely than this, I'll just live with it for the remaining life of the system (I hope it doesn't force me onto the evil Windows 8 sooner than I expected).

    ua549 and Joel, thanks for your help!!

Page 1 of 2 12 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts